OMNeT++/OMNEST Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000143OMNeT++IDE / C++ developmentpublic2010-03-08 18:402011-12-15 14:22
Reporterdrewhk 
Assigned Torhornig 
PrioritynormalSeveritymajorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version4.1b2 
Target VersionFixed in Version4.2 
Summary0000143: gdb fails to load from IDE
DescriptionTrying to debug my simulation from the IDE it reports the following:

.gdbinit: No such file or directory.
Reading symbols from D:\workspace\omnetpp\bionetssim\src\bionetssim.exe...done.

[New Thread 6616.0x17b4]
Error: dll starting at 0x770c0000 not found.
Error: dll starting at 0x76940000 not found.
Error: dll starting at 0x770c0000 not found.
Error: dll starting at 0x76fc0000 not found.
../../gdb-7.0/gdb/thread.c:79: internal-error: inferior_thread: Assertion `tp' failed.
A problem internal to GDB has been detected,
further debugging may prove unreliable.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000215)
andras (administrator)
2010-03-08 21:44

Wrong tree ;) OMNeT++'s C++ debugger comes from the Eclipse CDT project, which in turn relies on gdb, and here it looks very much like gdb crashed. OMNeT++ has nothing to do with that.

The issue should probably be submitted to the gdb bugtracker, with exact platform and gdb version information.
(0000317)
drewhk (reporter)
2010-06-23 13:58

I reopened the issue, as I found the fix.

The problem is that OMNeT++ bundles an old version of gdb that has known problems on 64bit systems. The fix is to overwrite it with the new 7.0.1 version:

http://sourceforge.net/downloads/mingw/MinGW/BaseSystem/GDB/GDB-7.0.1/ [^]
(0000318)
rhornig (administrator)
2010-06-23 14:26
edited on: 2010-06-23 14:29

Unfortunately, 7.0.1 also have problems so we had to revert back to the 6.6 version :( The set-environment command (which is used by the IDE to set the path for the debugged process) is not working on gdb 6.8 and 7.0.1... Sadly this means that you would not be able to debug certain projects at all, which is a showstopper...

See http://dev.omnetpp.org/bugs/view.php?id=161 [^] for further details.
http://sourceware.org/ml/gdb-patches/2010-05/msg00317.html [^]
https://sourceforge.net/tracker/index.php?func=detail&aid=2994861&group_id=2435&atid=102435 [^]

Seems that a patch was submitted to the mingw gdb team. We will revisit the issue for the next omnet release and try to update to the latest gdb if possible

(0000350)
rhornig (administrator)
2010-12-10 16:38

Seems that gdb 7.2 is available. Could you please recheck the *original* problem using i.e. debugging it on a 64 bit system) using the new gdb?

http://sourceforge.net/projects/mingw/files/MinGW/BaseSystem/GDB/GDB-7.2/gdb-7.2-1-mingw32-bin.tar.lzma/download [^]
(0000355)
rhornig (administrator)
2010-12-11 14:08

gdb 7.2 still suffers from the problem, so we will remain with gdb 6.6 for a while.
(0000564)
rhornig (administrator)
2011-09-20 15:26
edited on: 2011-09-20 15:27

gdb 7.3 still have this issue. A patch submitted on the gdb patches list:

http://sourceware.org/ml/gdb-patches/2011-09/msg00183.html [^]

Let's hope it will become mainstream.

(0000646)
rhornig (administrator)
2011-12-15 14:22

Now we have our own hand compiled gdb version patched with the necessary fixes.

- Issue History
Date Modified Username Field Change
2010-03-08 18:40 drewhk New Issue
2010-03-08 21:44 andras Note Added: 0000215
2010-03-08 21:45 andras Status new => closed
2010-03-08 21:45 andras Resolution open => no change required
2010-06-23 13:58 drewhk Note Added: 0000317
2010-06-23 13:58 drewhk Status closed => feedback
2010-06-23 13:58 drewhk Resolution no change required => reopened
2010-06-23 14:26 rhornig Note Added: 0000318
2010-06-23 14:29 rhornig Note Edited: 0000318
2010-12-10 16:38 rhornig Note Added: 0000350
2010-12-11 14:08 rhornig Note Added: 0000355
2010-12-11 14:08 rhornig Status feedback => postponed
2010-12-11 14:08 rhornig Resolution reopened => suspended
2011-09-20 15:26 rhornig Note Added: 0000564
2011-09-20 15:27 rhornig Note Edited: 0000564
2011-12-15 14:22 rhornig Note Added: 0000646
2011-12-15 14:22 rhornig Status postponed => resolved
2011-12-15 14:22 rhornig Fixed in Version => 4.2
2011-12-15 14:22 rhornig Resolution suspended => fixed
2011-12-15 14:22 rhornig Assigned To => rhornig


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker