OMNeT++/OMNEST Bug Tracker - OMNeT++
View Issue Details
0000202OMNeT++simulation kernelpublic2010-08-26 10:382012-01-09 17:54
lmcorreas 
 
normalcrashalways
feedbackopen 
4.1 
 
0000202: Segfault in parallel simulation
When I try to run parallel simulation of a scenario, I get the next results when simulator proceeds with the first event:

*** Process received signal ***
Signal: Segmentation fault (11)
Signal code: Address not mapped (1)
Failing at address: (nil)
[ 0] [0xc57410]
[ 1] escenario(_Z14check_and_castIP7cPacketET_P7cObject+0xa0) [0x8059b24]
[ 2] escenario(_ZN7L2Queue17startTransmittingEP8cMessage+0xb4) [0x805938a]
[ 3] escenario(_ZN7L2Queue13handleMessageEP8cMessage+0x3de) [0x805980a]
[ 4] /home/luisma/Escritorio/omnetpp-4.1/lib/liboppsimd.so(_ZN11cSimulation10doOneEventEP13cSimpleModule+0x1a8) [0xe7f70e]
[ 5] /home/luisma/Escritorio/omnetpp-4.1/lib/liboppcmdenvd.so(_ZN6Cmdenv8simulateEv+0x30f) [0x27a27f]
[ 6] /home/luisma/Escritorio/omnetpp-4.1/lib/liboppcmdenvd.so(_ZN6Cmdenv3runEv+0x4a5) [0x279d5f]
[ 7] /home/luisma/Escritorio/omnetpp-4.1/lib/liboppenvird.so(_ZN9EnvirBase3runEiPPcP14cConfiguration+0x15d) [0x657dbd]
[ 8] /home/luisma/Escritorio/omnetpp-4.1/lib/liboppenvird.so(_Z18setupUserInterfaceiPPc+0xb03) [0x654fcf]
[ 9] /home/luisma/Escritorio/omnetpp-4.1/lib/liboppenvird.so(main+0x4d) [0x655b7d]
[10] /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe6) [0x298bd6]
[11] escenario() [0x8054bc1]
*** End of error message ***
No tags attached.
Issue History
2010-08-26 10:38lmcorreasNew Issue
2012-01-09 17:54rhornigNote Added: 0000673
2012-01-09 17:54rhornigStatusnew => feedback

Notes
(0000673)
rhornig   
2012-01-09 17:54   
Need a bit more feedback to reproduce this. Like a sample project that consistently produces the crash.