OMNeT++/OMNEST Bug Tracker - OMNeT++
View Issue Details
0000981OMNeT++IDE / INI editorpublic2017-01-11 15:182017-01-27 13:32
till 
rhornig 
highmajoralways
resolvedfixed 
x86-64macOS10.12
5.1pre2 
5.1pre3 
0000981: ini-editor broken
It says: Failed to create the part's controls

See attached screenshot
No tags attached.
png screenshot-inieditor.png (504,329) 2017-01-11 15:18
https://dev.omnetpp.org/bugs/file_download.php?file_id=200&type=bug
log workspace.log (243,639) 2017-01-11 15:29
https://dev.omnetpp.org/bugs/file_download.php?file_id=201&type=bug
Issue History
2017-01-11 15:18tillNew Issue
2017-01-11 15:18tillFile Added: screenshot-inieditor.png
2017-01-11 15:29tillNote Added: 0001243
2017-01-11 15:29tillFile Added: workspace.log
2017-01-11 20:51tillNote Added: 0001245
2017-01-27 13:04rhornigNote Added: 0001271
2017-01-27 13:04rhornigStatusnew => resolved
2017-01-27 13:04rhornigFixed in Version => 5.1pre3
2017-01-27 13:04rhornigResolutionopen => fixed
2017-01-27 13:04rhornigAssigned To => rhornig

Notes
(0001243)
till   
2017-01-11 15:29   
Unfortunately my omnetpp workspace now won't start anymore. I attached the error.log from the workspace
(0001245)
till   
2017-01-11 20:51   
!ENTRY org.eclipse.ui 4 0 2017-01-11 21:50:44.190
!MESSAGE Unhandled event loop exception
!STACK 0
org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.NullPointerException)
    at org.eclipse.swt.SWT.error(SWT.java:4533)
    at org.eclipse.swt.SWT.error(SWT.java:4448)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:185)
    at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4032)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3708)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
    at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
    at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:138)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:497)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
Caused by: java.lang.NullPointerException
    at org.omnetpp.inifile.editor.form.FormPage.<init>(FormPage.java:85)
    at org.omnetpp.inifile.editor.form.ScrolledFormPage.<init>(ScrolledFormPage.java:23)
    at org.omnetpp.inifile.editor.form.GenericConfigPage.<init>(GenericConfigPage.java:75)
    at org.omnetpp.inifile.editor.form.InifileFormEditor.showCategoryPage(InifileFormEditor.java:178)
    at org.omnetpp.inifile.editor.form.InifileFormEditor$1.run(InifileFormEditor.java:124)
    at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:182)
    ... 23 more
(0001271)
rhornig   
2017-01-27 13:04   
This seems to be caused by an incorect native library build on macOS. I've rebuilt out buildmachine based on macOS 10.12