OMNeT++/OMNEST Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000146OMNeT++IDE / C++ developmentpublic2010-03-24 16:012010-03-29 21:55
Reportertobias 
Assigned Torhornig 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS VersionXP
Product Version 
Target VersionFixed in Version4.1b4 
Summary0000146: Invalid Address specified to RtlFreeHeap( 02800000, 6E188134 ) when executing tictoc.exe in gdb
DescriptionDebugging an applications developed with omnetpp4.1b3 is impossible on the mingw platform.

gdb aborts with:

warning: HEAP[tictoc.exe]:
warning: Invalid Address specified to RtlFreeHeap( 02800000, 6E188134 )
Program received signal SIGTRAP, Trace/breakpoint trap.
0x7c91120f in ntdll!DbgUiConnectToDbg () from D:\WINDOWS\system32\ntdll.dll
Steps To ReproduceUsed omnetpp4.1b3 without modification.
I run
./configure
make
cd samples/tictoc
gdb ./tictoc.exe
Derived projects like "oversim" show same behavior. Linux platform is not affected. Omnetpp 4.0 is not showing this behavior.
Additional InformationStarting program: d:\sim\omnetpp-4.1b3\samples\tictoc/./tictoc.exe
[New Thread 776.0x57c]
OMNeT++ Discrete Event Simulation (C) 1992-2010 Andras Varga, OpenSim Ltd.
Version: 4.1b3, build: 100311-af6d180, edition: Academic Public License -- NOT FOR COMMERCIAL USE
See the license for distribution terms and warranty disclaimer
warning: HEAP[tictoc.exe]:
warning: Invalid Address specified to RtlFreeHeap( 02800000, 6E188134 )


Program received signal SIGTRAP, Trace/breakpoint trap.
0x7c91120f in ntdll!DbgUiConnectToDbg () from D:\WINDOWS\system32\ntdll.dll
(gdb)

$ uname -a
MINGW32_NT-5.1 OSLO 1.0.11(0.46/3/2) 2009-07-11 17:46 i686 Msys

$ gcc -v
Using built-in specs.
Target: mingw32
Configured with: ../gcc-4.4.0/configure --enable-languages=c,ada,c++,fortran,java,objc,obj-c++ --disable-sjlj-exceptions
 --enable-shared --enable-libgcj --enable-libgomp --with-dwarf2 --disable-win32-registry --enable-libstdcxx-debug --enab
le-version-specific-runtime-libs --prefix=/mingw --with-gmp=/mingw/src/gmp/root --with-mpfr=/mingw/src/mpfr/root --build
=mingw32
Thread model: win32
gcc version 4.4.0 (GCC)

$ ld -v
GNU ld (GNU Binutils) 2.19.1
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000219)
rhornig (administrator)
2010-03-29 21:55

The issue caused by the fact that mingw 4.4 by default links with static stdc++ library, causing each shared library have its own instance. Unfortunately it is not possible to easily force mingw4.4 to compile with shared stdc++. Moved to GCC 4.5 pre version which correctly handles the issue and links with the shared stdc++ lib by default.

- Issue History
Date Modified Username Field Change
2010-03-24 16:01 tobias New Issue
2010-03-29 21:55 rhornig Note Added: 0000219
2010-03-29 21:55 rhornig Status new => resolved
2010-03-29 21:55 rhornig Fixed in Version => 4.1b4
2010-03-29 21:55 rhornig Resolution open => fixed
2010-03-29 21:55 rhornig Assigned To => rhornig
2010-03-29 21:55 rhornig Status resolved => closed


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker