OMNeT++/OMNEST Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000235OMNeT++IDE / NED editorpublic2011-01-03 10:552011-05-23 15:58
Reporterandras 
Assigned Tolevy 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version4.1 
Target VersionFixed in Version 
Summary0000235: Missing line info for elements added in graphical mode
DescriptionSymptom:

1. in graphics mode, add a submodule with an invalid type (add normally, then change the type in the Property editor to some invalid value)
2. switch to textual mode --> the error marker ("invalid type") will appear at the top of the buffer
3. change anything in the text editor --> error marker will jump to the correct line

Perhaps, when switching from graphical to text mode, the editor should re-parse the NED source to produce correct line info.



TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000454)
levy (developer)
2011-05-23 15:58

This problem arises in many other cases where a syntax error occurs during editing in the graphical editor and later switching to text mode. Moreover it also occurs without syntax errors: insert a valid parameter into a compound module, select one of the submodules, switch to text mode, the cursor does not point correctly to the selected submodule...

- Issue History
Date Modified Username Field Change
2011-01-03 10:55 andras New Issue
2011-05-20 10:43 levy Assigned To => levy
2011-05-23 15:58 levy Note Added: 0000454
2011-05-23 15:58 levy Status new => resolved
2011-05-23 15:58 levy Fixed in Version => 4.2b3
2011-05-23 15:58 levy Resolution open => fixed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker