OMNeT++/OMNEST Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000003OMNeT++IDE / C++ developmentpublic2008-11-24 04:222009-01-19 15:29
Reportermbergner 
Assigned Toandras 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version4.0b8 
Target VersionFixed in Version4.0rc2 
Summary0000003: IDE reports warnings as errors which are not errors
DescriptionWhen you import the INET framework and build it, you get a lot of errors. These are mostly compiler warnings which should be treated as such.

I would like to see those as warnings and not as errors, since errors signal (for me) a real problem that causes the simulation to not run or impact the linking.
An error should only occur if the executable/library could not be linked or if the simulation will definitely (without any chance that this is desired) is incorrect.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000008)
andras (administrator)
2008-11-24 04:47

Warnings are normally displayed as yellow "!" in the Problems View. Do you see warnings displayed as errors (red "x") in the Problems View? Please clarify!
(0000010)
mbergner (reporter)
2008-11-24 05:11

Yes, compiler warnings such as "unused variables" or "better put parenthesis around here" are displayed with as an error with a red x
(0000014)
andras (administrator)
2008-11-24 05:37
edited on: 2008-11-24 05:57

Thanks. What is your OS, compiler, compiler version? Also: what error parsers do you have selected on Project Properties -> C/C++Build -> Settings -> Error Parsers? What version of INET did you try? (We cannot reproduce this issue on Linux/gcc-4.3.2, nor with MinGW.)

(0000015)
mbergner (reporter)
2008-11-24 06:31

I use Ubuntu 8.10 (gcc-4.3.2) with INETMANET-20080920. Strange is however, that I don't have this error anymore. I had this on a similar machine with the same versions but now it is gone. There may have been leftovers from omnetpp-4.0b7. Well, consider this problem for now solved, I will however look at this a bit, since it is strange that all my errors disappear once I want to investigate them further. I should keep this skill ... .
(0000017)
andras (administrator)
2008-11-24 07:21

OK :) I'm closing this bug then (you can reopen it when the bug comes again)

> I had this on a similar machine with the same versions but now it is gone.
> There may have been leftovers from omnetpp-4.0b7.

Possible. b7 was bundled with CDT 5.0, for b8 we upgraded to CDT 5.0.1. Maybe the CDT team fixed this problem.
(0000018)
andras (administrator)
2008-11-24 07:22

Likely fixed in CDT 5.0.1
(0000102)
mbergner (reporter)
2009-01-05 08:54

This problem has reappeared with 4.0rc1. Just take an arbitrary c file, add a variable "int test;" somewhere and press ctrl-B (Build all), you get a red error marker for unused variable, which should only be a warning and not an error.
(0000103)
jeromerousselot (reporter)
2009-01-09 09:48

I observe the same issue on my system (omnet++ 4.0rc1 Ubuntu 8.10).
(0000105)
andras (administrator)
2009-01-09 13:09
edited on: 2009-01-09 13:09

This appears to be a problem in CDT's gcc error parser (project properties->settings->error parsers); this has been reported as
   https://bugs.eclipse.org/216443 [^] and
   https://bugs.eclipse.org/194173 [^]
Seems like it has problems with multi-line and/or localized messages (it checks for the literal word "warning" and doesn't understand it in other languages)

(0000107)
rhornig (administrator)
2009-01-19 11:38

We cannot reproduce this on our english systems but could you please try to export LANG=C
before starting the IDE? This would set the gcc error/warning messages to english (and hopefully solve the problem). If this fixes the issue we will add this to the omnetpp script... Thanks
(0000109)
mbergner (reporter)
2009-01-19 14:54

Indeed, with LANG=C the problem does not appear.
(0000110)
rhornig (administrator)
2009-01-19 15:29

added LAND=C to the omnetpp and omnest IDE start scripts

- Issue History
Date Modified Username Field Change
2008-11-24 04:22 mbergner New Issue
2008-11-24 04:22 mbergner Status new => assigned
2008-11-24 04:22 mbergner Assigned To => andras
2008-11-24 04:47 andras Note Added: 0000008
2008-11-24 04:52 andras Status assigned => feedback
2008-11-24 05:11 mbergner Note Added: 0000010
2008-11-24 05:37 andras Note Added: 0000014
2008-11-24 05:57 andras Note Edited: 0000014
2008-11-24 06:31 mbergner Note Added: 0000015
2008-11-24 07:21 andras Note Added: 0000017
2008-11-24 07:22 andras Status feedback => closed
2008-11-24 07:22 andras Note Added: 0000018
2008-11-24 07:22 andras Resolution open => unable to reproduce
2008-11-24 07:22 andras Fixed in Version => 4.0b8
2009-01-05 08:54 mbergner Note Added: 0000102
2009-01-05 08:54 mbergner Status closed => feedback
2009-01-05 08:54 mbergner Resolution unable to reproduce => reopened
2009-01-09 09:48 jeromerousselot Note Added: 0000103
2009-01-09 13:09 andras Note Added: 0000105
2009-01-09 13:09 andras Note Edited: 0000105
2009-01-19 11:38 rhornig Note Added: 0000107
2009-01-19 14:54 mbergner Note Added: 0000109
2009-01-19 15:29 rhornig Note Added: 0000110
2009-01-19 15:29 rhornig Status feedback => resolved
2009-01-19 15:29 rhornig Fixed in Version 4.0b8 => 4.0rc2
2009-01-19 15:29 rhornig Resolution reopened => fixed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker