OMNeT++/OMNEST Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000604OMNeT++IDE / result analysispublic2012-10-09 13:182012-10-15 10:13
Reporterpotys 
Assigned Totomi 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version4.2 
Target VersionFixed in Version 
Summary0000604: Displays names changing back to default dataset name.
Description If I provide any Display name for a line plotted other then the default data-set stored name, i cannot use it permanently, it is changing back to default whenever I change anything else in the properties, e.g. Symbol size of a line. (Hence Legend displayed names are changed back to default as well.)
Additional InformationSome color and line type settings are also lost after particular additional properties settings, but cannot reproduce that issue all the time, not obvious which settings steps results in loosing the previously adjusted settings.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000775)
andras (administrator)
2012-10-11 10:15

We found two issues related to this:
1. "Display name" was not used in scatter charts (we fixed it)
2. (on all charts) After having edited Display name or any other setting (ie. line width) for a line, selecting another line (without clicking Apply first) will lose your changes. That is, currently you have to click Apply after editing the Display name for a line, and only then can you go editing another line. We are working on this issue right now (the dialog will store your edits for all lines and will apply all of them on Apply or OK.)

Is it this (the 2nd) issue you were talking about, or is the bug something else? If so, it would be helpful if you could try and figure out what we have to do to reproduce it.
(0000776)
potys (reporter)
2012-10-11 11:59

Issue No. 2 is something I have also experienced, however the bug is not exactly this one. The problem is even if I click apply, then OK and go back to the plot and then to properties again, lets say changing the x Axis bounds Max value, the previously set display name will be changed back to default instead of the one which i set and saved. The same if I adjust e.g. the axes label, or anything else.
(However it seems like it remembers if I stay in the properties window, i have to go back to the plot with clicking ok, and go to properties again and whatever I do then it will results in restoring the name to default)
(0000777)
andras (administrator)
2012-10-11 13:18

OK, caught it: if *all* lines are selected and you change something else (e.g. line width), it will reset all display names! Fixing it.
(0000778)
tomi (developer)
2012-10-15 10:13

Fixed in 4.3.

- Issue History
Date Modified Username Field Change
2012-10-09 13:18 potys New Issue
2012-10-10 16:26 tomi Assigned To => tomi
2012-10-11 10:15 andras Note Added: 0000775
2012-10-11 11:59 potys Note Added: 0000776
2012-10-11 13:18 andras Note Added: 0000777
2012-10-15 10:13 tomi Note Added: 0000778
2012-10-15 10:13 tomi Status new => resolved
2012-10-15 10:13 tomi Resolution open => fixed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker