OMNeT++/OMNEST Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000794OMNeT++simulation kernelpublic2014-11-30 07:552014-11-30 07:57
Reporterandras 
Assigned Toandras 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version4.5 
Target VersionFixed in Version4.6 
Summary0000794: NED: pattern assignments of channel parameters doesn't work
DescriptionPattern assignments of channel parameters don't take effect. E.g. in the following example, channel parameters remain 0, despite the assignments in the parameters section:

network Test {
    parameters:
        **.datarate = 1Gbps;
        **.delay = 3ms;
    submodules:
        a: Node; // anything with an inout "g" gate
        b: Node;
    connections:
        a.g <--> ned.DatarateChannel <--> b.g;
}

TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000955)
andras (administrator)
2014-11-30 07:57

Fixed. The cause was that cNEDNetworkBuilder::assignParametersFromPatterns() run too early, when the channel was not yet installed on the gate.
    
Fix: move the call into cComponent::finalizeParameters()

- Issue History
Date Modified Username Field Change
2014-11-30 07:55 andras New Issue
2014-11-30 07:57 andras Note Added: 0000955
2014-11-30 07:57 andras Status new => resolved
2014-11-30 07:57 andras Fixed in Version => 4.6
2014-11-30 07:57 andras Resolution open => fixed
2014-11-30 07:57 andras Assigned To => andras
2015-10-12 09:28 ammmar1988 Issue cloned: 0000874


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker