OMNeT++/OMNEST Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000092OMNeT++simulation kernelpublic2009-08-10 21:352012-01-16 16:52
Reporterandras 
Assigned Torhornig 
PriorityhighSeveritymajorReproducibilityalways
StatusresolvedResolutionfixed 
Platformx86OSGNU/LinuxOS Version?
Product Version4.0 
Target VersionFixed in Version4.2.1 
Summary0000092: No large file support when compiled with default configuration on Linux
DescriptionOn Linux, simulations fail when the vector file's size reaches 2GB.

This can be fixed by adding -D_FILE_OFFSET_BITS=64 to configure.user. This should probably be the default.

See http://groups.google.com/group/omnetpp/browse_thread/thread/f5e394fbd7a9a60f/fe18c54d447cebfa?show_docid=fe18c54d447cebfa [^]

Actually, large file support should be the default (out of the box) setting for OMNeT++ on all platforms.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000203)
andras (administrator)
2010-01-09 09:27

Must be fixed for 4.1
(0000222)
rhornig (administrator)
2010-03-31 14:56

Large files are not supported by default on Linux (gcc)/mingw.
(0000320)
andras (administrator)
2010-06-26 10:07

Reopened because issue is still present in 4.1. Seems like the bug was closed without testing it.
(0000341)
miklos (reporter)
2010-11-29 00:07

I think the ide should also be tested before marking this as fixed, as in my experience it cannot open elog files larger than 2GB.
(0000342)
rhornig (administrator)
2010-12-08 15:58

Added the -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 macros to CFLAGS (for Linux/32-bit) to turn on the LFS support.

Tested LFS also on
- Mac OS 10.5 (passed) lfs seems to be default even on 32bit progs,
- Windows XP (with the bundled MINGW)) - also supports LFS
- and using the patch, Linux32 bit is also working.

For further info regarding GCC's LFS features:
http://www.suse.de/~aj/linux_lfs.html [^]
(0000690)
rhornig (administrator)
2012-01-16 16:51
edited on: 2012-01-16 16:54

ohh. Mingw build still not supported large files as of omnet 4.2.
With 4.2.1 mingw builds (including the uilib) should support large files. (added ftell64, fseek64 etc. macros for mingw in platmisc.h)


- Issue History
Date Modified Username Field Change
2009-08-10 21:35 andras New Issue
2009-08-13 11:15 andras Description Updated
2009-11-04 15:08 rhornig Priority normal => high
2010-01-09 09:27 andras Note Added: 0000203
2010-01-09 09:27 andras Severity minor => major
2010-01-09 09:27 andras Status new => confirmed
2010-01-09 09:32 andras Assigned To => rhornig
2010-03-31 14:56 rhornig Note Added: 0000222
2010-03-31 14:56 rhornig Status confirmed => resolved
2010-03-31 14:56 rhornig Fixed in Version => 4.1b1
2010-03-31 14:56 rhornig Resolution open => fixed
2010-06-26 10:07 andras Note Added: 0000320
2010-06-26 10:07 andras Status resolved => confirmed
2010-11-29 00:07 miklos Note Added: 0000341
2010-12-08 15:58 rhornig Note Added: 0000342
2010-12-08 15:58 rhornig Status confirmed => resolved
2010-12-08 15:58 rhornig Fixed in Version 4.1b1 => 4.2
2012-01-16 16:51 rhornig Note Added: 0000690
2012-01-16 16:52 rhornig Fixed in Version 4.2 => 4.2.1
2012-01-16 16:54 rhornig Note Edited: 0000690


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker